Need help with the napari.spatialdata Interactive() function

Hi spatialdata folks,

I am reproducing the notebook here:

But I am not able to get result from the Interactive() function, it shows the following error:
TypeError: Interactive.init() got an unexpected keyword argument ‘points’

And if I try running: Interactive([visium_sdata, xenium_sdata]), still get error:

I know it may be some silly mistake from my side, but I am grateful if you can help on this.

Hi Taobo thanks for reporting. This is a residual of us having used napari-spatialdata with the spatialdata branch instead of the main branch when running that notebook. We will fix it. For the time being please just remove the points argument. In case of other problems with napari we kindly ask you to report them and we will fix them. For temporary use the spatialdata branch is still available (but main will work as well).

I’m getting the same error when trying to load two spatialdata objects into napari.

Any fix for this yet? Thanks!

Thanks JurgenKriel, we have a fix that is almost ready to merge in this PR: You can already use it even if it is not merged to main (we are addressing some edge cases before merging, but it is already functioning).